hiteksoftware.com Forum Index hiteksoftware.com
User discussion forum
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Files not found using NT service - automize 7.43

 
Post new topic   Reply to topic    hiteksoftware.com Forum Index -> Frequently Asked Questions
View previous topic :: View next topic  
Author Message
rsamoose



Joined: 27 Oct 2008
Posts: 28
Location: Bethlehem, PA

PostPosted: Wed Jun 16, 2010 2:32 pm    Post subject: Files not found using NT service - automize 7.43 Reply with quote

I am able to run a directory loop task manually and with the desktop open and even with the desktop closed. However, if I restart the service after the desktop is closed- the files are no longer found. I can see the task run in the log file- so the scheduling appears to be correct.
I am using IP addresses to access the drives so hopefully the naming convention is okay.

I am logging into the desktop with the same username that starts the service.

Do you have any advice as to why the directory loop fails to recognize any files when running as a service when the user is logged off or even after the service is restarted with the user still logged in.

Thank you for your time.
Back to top
View user's profile Send private message
melvin
Site Admin


Joined: 25 May 2006
Posts: 635
Location: Santa Barbara, california

PostPosted: Wed Jun 16, 2010 8:56 pm    Post subject: Reply with quote

have you tried UNC conventions with share name? \\server\share...
see following article:
http://www.hiteksoftware.com/phpBB2/viewtopic.php?t=1667
Back to top
View user's profile Send private message Send e-mail
rsamoose



Joined: 27 Oct 2008
Posts: 28
Location: Bethlehem, PA

PostPosted: Thu Jun 17, 2010 4:10 am    Post subject: forgot to mention different workgroup/domain Reply with quote

I am unable to connect to the share using the computer name. Perhaps this occurs because it is part of a different workgroup, not on the same domain.
When I try to map a drive (for testing connectivity) using the computer name I get: "The drive cound not be mapped because no network was found".
I get an "invalid source directory" error when I use the computer name in one of my copy tasks. It works okay with the IP address.

Is the port still 1967 for Automize 7.43?

What versions of Windows server can be used to run Automize 7.43?
Is it capable of running on a 64 bit system?
Back to top
View user's profile Send private message
rsamoose



Joined: 27 Oct 2008
Posts: 28
Location: Bethlehem, PA

PostPosted: Mon Jun 21, 2010 8:06 am    Post subject: Directory loop on drive not on this domain? Reply with quote

Since the server I need to access is not on the domain (it is on a separate workgroup)- I am not able to share the folder using stardard methods.
Is there a way to access the folder in question using an IP address?
My task doesn't produce an error- it just doesn't 'see' any files.

Note It works fine when the task is run from the desktop. I need it to run from the NT service.

What versions of Windows server can be used to run Automize 7.43?
Is it capable of running on a 64 bit system?

Any advice will be greatly appreciated.
Back to top
View user's profile Send private message
melvin
Site Admin


Joined: 25 May 2006
Posts: 635
Location: Santa Barbara, california

PostPosted: Mon Jun 21, 2010 5:06 pm    Post subject: Reply with quote

what happens when you do:
\\ip_address\sharename\....

We have stopped supporting version 7 since it is past its EOL, and I have no idea if it would work with server 2008.
Back to top
View user's profile Send private message Send e-mail
rsamoose



Joined: 27 Oct 2008
Posts: 28
Location: Bethlehem, PA

PostPosted: Tue Jun 22, 2010 5:27 am    Post subject: Connection from domain to workgroup Reply with quote

Here is a snapshot of the logs when the directory is entered as follows: \\111.22.333.44\C$\FTPRoot\BCS_SFTP\...:

Manually Run-- (works fine)
Jun 22, 2010 8:58:32 AM
Directory Loop - FHB-_SFTP_DirectoryLoop - Manual Run
Jun 22, 2010 8:58:32 AM
Directory Loop - FHB-_SFTP_DirectoryLoop - Start Instance = 749
Jun 22, 2010 8:58:32 AM
Directory Loop - FHB-_SFTP_DirectoryLoop - Following file was found in directory : GUREPT.TXT
Jun 22, 2010 8:58:32 AM
Directory Loop - FHB-_SFTP_DirectoryLoop - Following file was found in directory : HIREPT.TXT
Jun 22, 2010 8:58:32 AM
Directory Loop - FHB-_SFTP_DirectoryLoop - Files passing criteria = 2
Jun 22, 2010 8:58:32 AM
Directory Loop - FHB-_SFTP_DirectoryLoop - Maximum loops = 2
Jun 22, 2010 8:58:32 AM
Directory Loop - FHB-_SFTP_DirectoryLoop - 0. Variables set for: GUREPT.TXT
Jun 22, 2010 8:58:32 AM
Directory Loop - FHB-_SFTP_DirectoryLoop - 0. Running Task: FHB-TEST-Echo
Jun 22, 2010 8:58:32 AM
Echo - FHB-TEST-Echo - Manual Run
Jun 22, 2010 8:58:32 AM
Echo - FHB-TEST-Echo - Start Instance = 389
Jun 22, 2010 8:58:32 AM
Echo - FHB-TEST-Echo - FHB-TEST20100615-Test Echo message
Jun 22, 2010 8:58:33 AM
Echo - FHB-TEST-Echo - End Instance = 389 , Exit Code = 0 , Runtime (ms) = 47
Jun 22, 2010 8:59:12 AM
Directory Loop - FHB-_SFTP_DirectoryLoop - 1. Variables set for: HIREPT.TXT
Jun 22, 2010 8:59:12 AM
Directory Loop - FHB-_SFTP_DirectoryLoop - 1. Running Task: FHB-TEST-Echo
Jun 22, 2010 8:59:12 AM
Echo - FHB-TEST-Echo - Manual Run
Jun 22, 2010 8:59:13 AM
Echo - FHB-TEST-Echo - Start Instance = 390
Jun 22, 2010 8:59:13 AM
Echo - FHB-TEST-Echo - FHB-TEST20100615-Test Echo message
Jun 22, 2010 8:59:13 AM
Echo - FHB-TEST-Echo - End Instance = 390 , Exit Code = 0 , Runtime (ms) = 63
Jun 22, 2010 8:59:52 AM
Directory Loop - FHB-_SFTP_DirectoryLoop - End Instance = 749 , Exit Code = -100 , Runtime (ms) = 80219

Next I started the NT service, shutdown the user interface, restarted the NT service and logged off the system: (Files are not recognized)
Jun 22, 2010 9:02:00 AM
Directory Loop - FHB-_SFTP_DirectoryLoop - Schedule Title = FHB-_SFTP_DirectoryLoop , Scheduled execution time = Jun 22, 2010 9:02:00 AM
Jun 22, 2010 9:02:00 AM
Directory Loop - FHB-_SFTP_DirectoryLoop - Start Instance = 750
Jun 22, 2010 9:02:00 AM
Directory Loop - FHB-_SFTP_DirectoryLoop - End Instance = 750 , Exit Code = 3 , Runtime (ms) = 125
Jun 22, 2010 9:04:00 AM
Directory Loop - FHB-_SFTP_DirectoryLoop - Schedule Title = FHB-_SFTP_DirectoryLoop , Scheduled execution time = Jun 22, 2010 9:04:00 AM
Jun 22, 2010 9:04:00 AM
Directory Loop - FHB-_SFTP_DirectoryLoop - Start Instance = 751
Jun 22, 2010 9:04:00 AM
Directory Loop - FHB-_SFTP_DirectoryLoop - End Instance = 751 , Exit Code = 3 , Runtime (ms) = 78
Jun 22, 2010 9:06:00 AM
Directory Loop - FHB-_SFTP_DirectoryLoop - Schedule Title = FHB-_SFTP_DirectoryLoop , Scheduled execution time = Jun 22, 2010 9:06:00 AM
Jun 22, 2010 9:06:01 AM
Directory Loop - FHB-_SFTP_DirectoryLoop - Start Instance = 752
Jun 22, 2010 9:06:01 AM
Directory Loop - FHB-_SFTP_DirectoryLoop - End Instance = 752 , Exit Code = 3 , Runtime (ms) = 125

Finally- Log back on system, stop service and start user interface (Works okay):
Jun 22, 2010 9:08:00 AM
Directory Loop - FHB-_SFTP_DirectoryLoop - Schedule Title = FHB-_SFTP_DirectoryLoop , Scheduled execution time = Jun 22, 2010 9:08:00 AM
Jun 22, 2010 9:08:00 AM
Directory Loop - FHB-_SFTP_DirectoryLoop - Start Instance = 753
Jun 22, 2010 9:08:00 AM
Directory Loop - FHB-_SFTP_DirectoryLoop - Following file was found in directory : GUREPT.TXT
Jun 22, 2010 9:08:00 AM
Directory Loop - FHB-_SFTP_DirectoryLoop - Following file was found in directory : HIREPT.TXT
Jun 22, 2010 9:08:00 AM
Directory Loop - FHB-_SFTP_DirectoryLoop - Files passing criteria = 2
Jun 22, 2010 9:08:00 AM
Directory Loop - FHB-_SFTP_DirectoryLoop - Maximum loops = 2
Jun 22, 2010 9:08:01 AM
Directory Loop - FHB-_SFTP_DirectoryLoop - 0. Variables set for: GUREPT.TXT
Jun 22, 2010 9:08:01 AM
Directory Loop - FHB-_SFTP_DirectoryLoop - 0. Running Task: FHB-TEST-Echo
Jun 22, 2010 9:08:01 AM
Echo - FHB-TEST-Echo - Manual Run
Jun 22, 2010 9:08:01 AM
Echo - FHB-TEST-Echo - Start Instance = 391
Jun 22, 2010 9:08:01 AM
Echo - FHB-TEST-Echo - FHB-TEST20100615-Test Echo message
Jun 22, 2010 9:08:01 AM
Echo - FHB-TEST-Echo - End Instance = 391 , Exit Code = 0 , Runtime (ms) = 47
Jun 22, 2010 9:08:41 AM
Directory Loop - FHB-_SFTP_DirectoryLoop - 1. Variables set for: HIREPT.TXT
Jun 22, 2010 9:08:41 AM
Directory Loop - FHB-_SFTP_DirectoryLoop - 1. Running Task: FHB-TEST-Echo
Jun 22, 2010 9:08:41 AM
Echo - FHB-TEST-Echo - Manual Run
Jun 22, 2010 9:08:41 AM
Echo - FHB-TEST-Echo - Start Instance = 392
Jun 22, 2010 9:08:41 AM
Echo - FHB-TEST-Echo - FHB-TEST20100615-Test Echo message
Jun 22, 2010 9:08:41 AM
Echo - FHB-TEST-Echo - End Instance = 392 , Exit Code = 0 , Runtime (ms) = 47
Jun 22, 2010 9:09:21 AM
Directory Loop - FHB-_SFTP_DirectoryLoop - End Instance = 753 , Exit Code = -100 , Runtime (ms) = 80281

I will send screen shot of Directory loop set-up and output log in an email.

Also, is Automize 9.x compatable with Windows Server 2003 and/or 2008?

Thank you!
Back to top
View user's profile Send private message
rsamoose



Joined: 27 Oct 2008
Posts: 28
Location: Bethlehem, PA

PostPosted: Wed Jun 23, 2010 12:24 pm    Post subject: Is this issue resolved in Version 9.X? Reply with quote

Does Automize version 9.x support the NT service transferring files between a workgroup and a domain?
Back to top
View user's profile Send private message
Robert
Site Admin


Joined: 25 May 2006
Posts: 1140

PostPosted: Tue Jun 29, 2010 9:13 am    Post subject: Reply with quote

1) Automize 9 is compatible with all windows from 2000-2008 and windows 7 etc..
2) Once the service is started all permissions are controlled by the domain / workgroup. Automize does not control this. So the transfer of files between workgroup and domain is governed by your own network rules.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    hiteksoftware.com Forum Index -> Frequently Asked Questions All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group