NT service results in Private key not found

Discuss encryption/decryption issues

NT service results in Private key not found

Postby melvin » Mon Dec 18, 2006 10:46 am

user support request:

I've search your knowledgebase and forums for this AuoKrypt output logs error:

gpg: skipped "remove <remove.com>": secret key not available
gpg: C:\......txt: sign+encrypt failed: secret key not available

This problem only started recently after upgrading to 7.x. If we delete all keys in the Key Store and start from scratch, here is what we do:

1) Click Import to import the keys.
2) Two keys appear, a public and a private, both entitled "remove<remove.com>".
3) Although this doesn't seem to make a difference, I set the trust level for the public key to ultimate.
4) Run the task and the output logs show the message above.

What are we doing wrong?
melvin
Site Admin
 
Posts: 979
Joined: Thu May 25, 2006 10:20 am
Location: Santa Barbara, california

Postby melvin » Mon Dec 18, 2006 10:46 am

1) Are you using NT service?
2) Is the engine already running as user1, then you logged on as user2 and imported the keys?
3) What is the keystore folder? is it the logged on users home directory?
melvin
Site Admin
 
Posts: 979
Joined: Thu May 25, 2006 10:20 am
Location: Santa Barbara, california

Postby melvin » Mon Dec 18, 2006 10:46 am

user reply:

1) Yes, running as service
2) Running as Local System Account (no desktop interaction). Logged on and imported as Administrator.
3) c:/Documents and Settings/Administrator/Application Data/gnupg/

We changed the runnable user to the Administrator account and it worked. I understand the problem now and will work around that understanding. Ideally we like to create accounts for services so the admin account isn't exposed and the services don't fail when we change the admin password occasionally.
Last edited by melvin on Mon Dec 18, 2006 10:50 am, edited 1 time in total.
melvin
Site Admin
 
Posts: 979
Joined: Thu May 25, 2006 10:20 am
Location: Santa Barbara, california

Postby melvin » Mon Dec 18, 2006 10:50 am

The whole issue is likely to be due to premissions for the local service since the key is in the 'Administrator' home directory.
Look at the following article in the Encryption forum:
How to change the default GnuPG home directory (keystore)
melvin
Site Admin
 
Posts: 979
Joined: Thu May 25, 2006 10:20 am
Location: Santa Barbara, california


Return to Encryption/Decryption

Who is online

Users browsing this forum: No registered users and 3 guests

cron