Upgrading from 7.x/8.x/9.x/10.x/11.x to 12.x

Frequently asked questions

Upgrading from 7.x/8.x/9.x/10.x/11.x to 12.x

Postby melvin » Tue Dec 03, 2013 5:42 pm

* 12.x can be run on same system as the older versions. HOWEVER, if you are using GPG encryption, older versions GPG v1 encryption data is converted to GPG v2 format. So, if you are using encryption, and still wish to use the older version, then you have to run/test 12.x on a different system!!

* Test 12.x fully before you uninstall the old version.

* Install 12.x and open user interface.

* VERY IMPORTANT: Settings menu / Password encryption. Make sure the java key matches on both systems. Else you will have to re-enter all the passwords.

* Convert old version settings (New software installed on same computer):
File menu - Convert 7.x/8.x/9.x/10.x/11.x data - Point to the old versions 'data' folder.
example: ......\automize11\data or .....\jasftp11\data or ...\autokrypt10\data

* Convert old version settings (If you are also moving the software to a new computer)
Old Computer - File menu / Backup - Backup to EMPTY network folder X
New Computer - File menu / Convert 7.x/8.x/9.x/10.x/11/x data - Point to the folder X above

* Generate new license key. The information needed to generate a license key was sent to you via email when you purchased the software.

* If you have changed computers also AND if you are using Encryption:
a) If you have just a few keys, you can export each key from the old computer keystore to a File. Then import the key into the new computer keystore.
b) If you have many keys, you can copy the contents of the entire KeyStore folder from the old computer to KeyStore folder on the new computer. The keystore folder path is listed at the bottom of the KeyStore Tab.

* If your passwords (FTP, Email etc..) do not work, then it is likely that you have set the java password encryption key. Settings menu / Password encryption. Make sure the encryption method and java key match both systems. Else you will have to re-enter all the passwords.

* If you were using Database SQL task to an ODBC database using the sun.jdbc.odbc.JdbcOdbcDriver driver built into java, your task will fail. This is because Version 12 uses Java 11, and the sun.* classes have been removed from java 11. You can contact us with your Database type and we will let you know the required JDBC driver and documentation.

* Uninstalling old version:
First remove old version service
Old Version - User interface / Engine Menu / Service Module.
Stop the Service (if service is running).
Uninstall/Remove the service
Stop the old version Engine.
Close down the old versions user interface.

* Uninstall the old version from control panel (windows) or delete install folder (mac, linux)
Last edited by Tech Support on Sun Jun 09, 2019 7:26 pm, edited 6 times in total.
Reason: new version
melvin
Site Admin
 
Posts: 983
Joined: Thu May 25, 2006 10:20 am
Location: Santa Barbara, california

Return to Frequently Asked Questions

Who is online

Users browsing this forum: No registered users and 7 guests

cron