Connecting to MS SQL database using version 11

Dissuss issues not related to other forums

Connecting to MS SQL database using version 11

Postby melvin » Wed Aug 05, 2015 5:41 am

User support request:

We have recently upgraded from Automize v10.25 to v11.3. The Database SQL function which performs a SQL enquiry against a MS Sequel 2005 database via a locally defined Data Source no longer works. I found it mentioned in the forums as below (extract):
6) If you were using Database SQL task to an ODBC database using the sun.jdbc.odbc.JdbcOdbcDriver driver built into java, your task will fail. This is because Version 11 uses Java 8, and the sun.* classes have been removed from java 8. You can contact us with your Database type and we will let you know the required JDBC driver and documentation.

viewtopic.php?f=22&t=2853&p=5403&hilit=sun.jdbc.odbc.JdbcOdbcDriver#p5403


Can you please provide the JDBC details for Automize v11.
melvin
Site Admin
 
Posts: 983
Joined: Thu May 25, 2006 10:20 am
Location: Santa Barbara, california

Re: Connecting to MS SQL database using version 11

Postby melvin » Wed Aug 05, 2015 5:42 am

The download is:
https://www.microsoft.com/en-us/downloa ... n&id=11774

IMPORTANT: MS SQL server 2005 needs driver version 4.0. (NOT 4.1 or 4.2)
IMPORTANT: MS SQL server 2008 or 2012 can use driver version 4.1 or later.

You have to copy the .jar or .zip driver to both Automize main folder and to Automize\jre\lib\ext folder

The connection information is here:
https://msdn.microsoft.com/en-us/librar ... 10%29.aspx
melvin
Site Admin
 
Posts: 983
Joined: Thu May 25, 2006 10:20 am
Location: Santa Barbara, california

Re: Connecting to MS SQL database using version 11

Postby melvin » Wed Aug 05, 2015 5:42 am

User response:

Thank you for that information.
In addition to copying the sqljdbc4.jar file to both the main Automize folder and also to the Automize Java “…\jre\lib\ext” subfolder, also copy the file sqljdbc_auth.dll (32bit version) from the same Microsoft installation package to “…\jre\bin” folder. Without it the Automize server is unable to automatically pass user credentials to the MS Sequel server. Turn on the Integrated Security option in the URL (see below) to enable it.

Driver class name: “com.microsoft.sqlserver.jdbc.SQLServerDriver”
Database URL: ‘jdbc:sqlserver://{ServerName}:{PortNo};integratedSecurity=true’
melvin
Site Admin
 
Posts: 983
Joined: Thu May 25, 2006 10:20 am
Location: Santa Barbara, california


Return to Other

Who is online

Users browsing this forum: No registered users and 2 guests

cron